Microsoft Announces Internet Explorer Security Vulnerability

Dawn Irish
Monday, April 28, 2014 - 4:45pm

On Saturday, April 26, Microsoft released a security advisory announcing a vulnerability in all versions of Internet Explorer (IE) that could allow an attacker full access to a user’s computer. 

TTS expects Microsoft to release a patch for this vulnerability in the near future.  We recommend applying that patch as soon as it is available, and avoiding the use of Internet Explorer in the meantime as a precaution.  Please be aware that this is the first vulnerability that will not be patched in Windows XP, as Microsoft ended support for the operating system on April 8, 2014. 

If you would like more information on this vulnerability please contact the TTS Service Desk at 617-627-3376.